FFC probems Install Fenics for Python3 on Ubuntu 18.04


225
views
0
3 months ago by
I am currently trying to install Fenics for python3 (already got it for Python2) by

git clone https://bitbucket.org/fenics-project/fiat
git clone https://bitbucket.org/fenics-project/instant
git clone https://bitbucket.org/fenics-project/dijitso
git clone https://bitbucket.org/fenics-project/ufl
git clone https://bitbucket.org/fenics-project/ffc
git clone https://bitbucket.org/fenics-project/dolfin
git clone https://bitbucket.org/fenics-project/mshr
cd fiat    && pip3 install .
cd instant && pip3 install .
cd dijitso && pip3 install .
cd ufl     && pip3 install .
cd ffc     && pip3 install .
cd dolfin  && mkdir build && cd build && cmake .. && make install
cd mshr    && mkdir build && cd build && cmake .. && make install​

But problems happened for 'cd ffc && pip3 install .'

wanting-virtual-machine:~/ffc$ pip3 install .
Processing /home/wanting/ffc
Collecting numpy (from fenics-ffc==2018.1.0.dev0)
Using cached https://files.pythonhosted.org/packages/71/90/ca61e203e0080a8cef7ac21eca199829fa8d997f7c4da3e985b49d0a107d/numpy-1.14.3-cp36-cp36m-manylinux1_x86_64.whl
Collecting fenics-fiat<2018.2,>=2018.1.0.dev0 (from fenics-ffc==2018.1.0.dev0)
Could not find a version that satisfies the requirement fenics-fiat<2018.2,>=2018.1.0.dev0 (from fenics-ffc==2018.1.0.dev0) (from versions: 2017.1.0.post1, 2017.2.0)
No matching distribution found for fenics-fiat<2018.2,>=2018.1.0.dev0 (from fenics-ffc==2018.1.0.dev0)

does anyone know how to fix it? I have stuck on it for the whole night....
Community: FEniCS Project
Please login to add an answer/comment or follow this question.

Similar posts:
Search »