Issue with installation Wing IDE on kali - libpango1.0-0 dependency - libpango1.0-0 vs libpango-1.0-0 (additional '-' )

6 months ago by
I have some issue with the installation on kali linux and the libpango. I have 'libpango-1.0-0' but it wants "libpango1.0-0" so without a ' - ' before '1'

I tried to instal libpango1.0-0 but I have got (and I already have the 'libpango-1.0-0'):
Package libpango1.0-0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source
However the following packages replace it:
  libpango-1.0-0 libpangoft2-1.0-0
  libpangocairo-1.0-0 libpangoxft-1.0-0

and when I try to instal it I get dependency problems because it wants the name without the ' - '
# dpkg -i wingide6_6.0.9-1_amd64.debSelecting previously unselected package wingide6.
(Reading database ... 319380 files and directories currently installed.)
Preparing to unpack wingide6_6.0.9-1_amd64.deb ...
Unpacking wingide6 (6.0.9-1) ...
dpkg: dependency problems prevent configuration of wingide6:
wingide6 depends on libpango1.0-0 (>= 1.18.0); however:
  Package libpango1.0-0 is not installed.

dpkg: error processing package wingide6 (--install):
dependency problems - leaving unconfigured
Processing triggers for menu (2.1.47+b1) ...
Errors were encountered while processing:
Community: Wing Python IDE
The newest one (wingide6 (6.0.9-1))- I've downloaded it yesterday
written 6 months ago by Paweł Krawczyk  
I've installed  older version (5.1.12) with no issues - so looks that the issue is just for the new one
written 6 months ago by Paweł Krawczyk  
OK, thanks for letting us know.  What version of Kali is it, so we can try it here?
written 6 months ago by Wingware Support  
np, it's Kali 2017.3
written 6 months ago by Paweł Krawczyk  
Great, thanks, we'll look at it.  Won't be fixed in 6.0.10, though, because that was already built.  If you do try --force-depends it looks like you may need to uninstall Wing again before each apt-get update, if the link I referenced below is still correct.
written 6 months ago by Wingware Support  
ok, no problem - I see no issue in the 5.1 version
written 6 months ago by Paweł Krawczyk  

1 Answer

6 months ago by
What version of Wing is this?  I'm surprised it depends on libpango... I'm fairly sure we don't use that.  Also, I'm fairly sure this is just gratuitous dist-to-dist package renaming, which is the reason Wing tries to depend on nothing except for glibc and a few other things at the low level.  In practice, unfortunately, this is practically a full time job to get right.  I wish Linux would get its act together in this regard.

In any case, I suspect the solution is to force dpkg to ignore dependencies with the --ignore-dependencies flag or --force-depends although the latter might cause problems later as mentioned in

Please let us know if this does not help.
Please login to add an answer/comment or follow this question.

Similar posts:
Search »