Cannot connect to remote host

9 months ago by

I'm having trouble connecting to a remote host and the message provided is not helpful. This appears to be a generic error message when probing and can be caused by various things. Are there any steps I should be taking in general to debug this error? 


I'm running Windows 10 Pro and am connecting to Ubuntu on Bash/WSL


Connecting to host id test failed. Please check your configuration. Output received:

Connecting to ::1 port 2200 
We claim version: SSH-2.0-PuTTY_Release_0.69 
Server version: SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.1 
Using SSH protocol version 2 
Doing ECDH key exchange with curve Curve25519 and hash SHA-256 
Server also has ecdsa-sha2-nistp256/ssh-rsa host keys, but we don't know any of them 
Host key fingerprint is: 
ssh-ed25519 256 52:36:b1:ff:c0:c4:1c:54:8e:d4:5a:47:22:3f:f2:1c 
Initialised AES-256 SDCTR client->server encryption 
Initialised HMAC-SHA-256 client->server MAC algorithm 
Initialised AES-256 SDCTR server->client encryption 
Initialised HMAC-SHA-256 server->client MAC algorithm 
Pageant is running. Requesting keys. 
Pageant has 1 SSH-2 keys 
Using username "ubuntu". 
Trying Pageant key #0 
Authenticating with public key "rsa-key-20170615" from agent 
Sending Pageant's response 
Access granted 
Opening session as main channel 
Opened main channel 
Requesting remote port 50010 forward to 
Remote port forwarding from 50010 enabled 
Started a shell/command 
Created meta importer
(' Added dir', '/home/ubuntu/winghome/bin/dbg/src/debug')
(' Added dir', '/home/ubuntu/winghome/src/debug')
(' Added dir', '/home/ubuntu/winghome/bin/dbg/src/wingbase')
(' Added dir', '/home/ubuntu/winghome/src/wingbase')
Server sent command exit status 0 
SSH client exited errno=0
Community: Wing Python IDE

Could you send the ~/.wingide6/remote-agent.log from the Ubuntu machine to

written 9 months ago by Wingware Support  

I've sent over the log, I should note that I received that same error in different scenarios and they should all be included in the log.


I'm running Windows 10 and Ubuntu is running on the same machine via Bash/WSL

written 9 months ago by Jonathan  
Please login to add an answer/comment or follow this question.

Similar posts:
Search »