Spyder launch problem under fenicsproject application (Mac, anaconda, Spyder 3.3)


34
views
0
20 days ago by
DF  
I installed fenicsproject in Anaconda following the commands provided in the site:

conda create -n fenicsproject -c conda-forge fenics
source activate fenicsproject

I had already installed the Anaconda Navigator environment.

When trying to open Spyder with Applications on:  fenicsproject

the following error window appears:

I would appreciate any help.

Traceback (most recent call last):
File "/anaconda3/envs/fenicsproject/bin/spyder", line 7, in
from spyder.app.start import main
File "/anaconda3/envs/fenicsproject/lib/python3.6/site-packages/spyder/app/start.py", line 12, in
import zmq
File "/anaconda3/envs/fenicsproject/lib/python3.6/site-packages/zmq/__init__.py", line 42, in
_load_libzmq()
File "/anaconda3/envs/fenicsproject/lib/python3.6/site-packages/zmq/__init__.py", line 13, in _load_libzmq
PYPY = platform.python_implementation().lower() == 'pypy'
File "/anaconda3/envs/fenicsproject/lib/python3.6/platform.py", line 1234, in python_implementation
return _sys_version()[0]
File "/anaconda3/envs/fenicsproject/lib/python3.6/platform.py", line 1192, in _sys_version
repr(sys_version))
ValueError: failed to parse CPython sys.version: '3.6.5 |Anaconda, Inc.| (default, Mar 29 2018, 13:14:23) \n[GCC 4.2.1 Compatible Clang 4.0.1 (tags/RELEASE_401/final)]'


Community: FEniCS Project
Please login to add an answer/comment or follow this question.

Similar posts:
Search »