Error: Could not import roadrunner


46
views
0
5 weeks ago by
Hi all

I am trying to install compucell3D on ubuntu 16.04 LTS. I followed the steps mentioned on the tutorial page (http://www.compucell3d.org/SrcBin/LinuxCompile). Everything went smoothly, except for the last step, where I run compucell3D using ./compucell3d.sh, ad it gives the following error:

./compucell3d.sh: 10: ./compucell3d.sh: Bad substitution
CompuCell3D - version 3.7.7
['/home/jairaj/cc3D_install/player5', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/home/jairaj/.local/lib/python2.7/site-packages', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages']
Could not import roadrunner
Segmentation fault (core dumped)

Can someone let me know what is going on? Here are the specs for my machine:
RAM: 32 GB
Processor: Intel® Xeon(R) CPU E5-2687W v3 @ 3.10GHz × 20
graphics: NVS 310/PCIe/SSE2

Thanks a lot!
Community: CompuCell3D

1 Answer


0
4 weeks ago by
how did you install libroadrunner? Are you on physical machine or running inside virtual machine?

another option is to use conda to install cc3d:

Here is a link:
http://www.compucell3d.org/SrcBin/CompilingOnLinux2017

One of the prerequisites here is that you install miniconda before trying this way of installing CC3D

Here is a link

https://conda.io/miniconda.html
Please login to add an answer/comment or follow this question.

Similar posts:
Search »