WingIDE fails to reconnect to remote host after change of IP?


38
views
0
19 days ago by
Amit  
Hi, The following scenario causes the IDE to get stuck: 1) Use the IDE with a remote project. 2) Sleep/hibernate the computer (while the IDE is still open). 3) Change LAN connection (e.g. go from office->home). 4) Open the computer. 5) The IDE seems responsive but I am not able to save/open new files on the remote project. 6) I am able to probe the remote host successfully. 7) Trying to close the project makes the IDE stuck. The only way to recover this situation is to kill the IDE (externally from process explorer) and restart it. I am using the latest WingIDE on windows 7 x64. Amit
add commentfollow this post modified 19 days ago by Wingware Support   • written 19 days ago by Amit  

Thanks, I'll take a look at this.  It may also work to kill Wing's reverse SSH tunnel to the remote host.  I think what is happening is Wing is stuck to the old hung SSH tunnel and not realizing the remote agent isn't answering anymore.  Killing the tunnel (on the same machine where the IDE is running) should clear that.

Also, can you please let me know which Wing version you have?  Some issues related to not being be able to close projects in a case like this should be fixed in 6.0.5 (the latest at this moment) but it's possible this case is different.

Thanks!

written 19 days ago by Wingware Support  

Is there an easy way to kill the SSH tunnel?

I am using the latest version of WingIDE. My local machine is Windows 7 x64, the remote is an ubuntu.

Amit

written 19 days ago by Amit  

I think just with Task Manager.  If using putty the process is plink.exe.  Or for now it may be easier to just restart Wing in this case, or quit before leaving the old LAN.  It's obviously a bug we need to fix...

written 19 days ago by Wingware Support  
Please log in to add an answer/comment or follow this question.

Share this question


Similar posts:
Search »