Can't run demo_poisson.py I get an error with CXXABI_1.3.9


84
views
1
6 weeks ago by

Hello,

I'm new to fenics. I tried to test my install by running demo_poission.py from http://fenics.readthedocs.io/projects/dolfin/en/2017.2.0/demos/poisson/python/demo_poisson.py.html

I get the following:

(fenicsproject) patel@MAE-HNC095503D ~/fenics scripts $ python demo_poisson.py
Solving linear variational problem.
Traceback (most recent call last):
File "demo_poisson.py", line 188, in <module>
import matplotlib.pyplot as plt
File "/home/patel/.conda/envs/fenicsproject/lib/python3.6/site-packages/matplotlib/pyplot.py", line 31, in <module>
import matplotlib.colorbar
File "/home/patel/.conda/envs/fenicsproject/lib/python3.6/site-packages/matplotlib/colorbar.py", line 32, in <module>
import matplotlib.artist as martist
File "/home/patel/.conda/envs/fenicsproject/lib/python3.6/site-packages/matplotlib/artist.py", line 16, in <module>
from .path import Path
File "/home/patel/.conda/envs/fenicsproject/lib/python3.6/site-packages/matplotlib/path.py", line 21, in <module>
from . import _path, rcParams
ImportError: /home/patel/.conda/envs/fenicsproject/lib/python3.6/site-packages/dolfin/../../../libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/patel/.conda/envs/fenicsproject/lib/python3.6/site-packages/matplotlib/_path.cpython-36m-x86_64-linux-gnu.so)

I updated libgcc like suggested in one of the posts somewhere but that didn't work.

Please help?

Thanks,
Japan







Community: FEniCS Project

1 Answer


0
4 weeks ago by
ac  
Hi,

Is the problem still open ?

Can you type
source activate alias-of_you_env
conda list

and copy paste the result ?

I'm not an expert in anaconda installation but  I've been through a similar problem last week.
Please login to add an answer/comment or follow this question.

Similar posts:
Search »